SAP Knowledge Base Article - Public

3504805 - IPS Sync of users fails with an HTTP 429 Response Code

Symptom

Sync users is not possible for embedded SAC system

Environment

  • Embedded SAP Analytics Cloud
  • Enterprise SAP Analytics Cloud

Reproducing the Issue

  1. Login to IPS
  2. Run sync job
  3. Notice that it is failing and the job has been terminated
  4. In the IPS logs, there are many errors with 429 response codes

Cause

  • The rate limit for SCIM API is 500 req/hr and 10 req/min as per SAC product design. The user sync is sending more than 10 req/min at times which is causing the excess requests to get 429 response that cause the issue.

Resolution

  • Lower the request rate from user side.

Keywords

SAC, Too ,many ,requests , SYNC , OEM, IPS, limit   , KBA , LOD-ANA-GTW , Gateway for SAP Analytics Cloud API , Problem

Product

SAP SuccessFactors HCM Core 2405