Symptom
When logging into CPQ, you see some error on the login page, and there is no other icon on the page, not even Setup icon, or Developer Console icon.
This hinders us from doing anything in CPQ, and it affects a lot of users.
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
Try to login to CPQ with credentials or via SSO login.
Cause
Such an issue could be caused due to UI customizations in the Main Menu template.
Resolution
- You would need to fix your Main Menu Responsive template in order to be able to access the Home page.
- You can disable the UI customizations, by going to the Developer console even though you don't see any icon.
- Please type /DeveloperConsole after your environment URL.
Eg: <CPQ Url>/DeveloperConsole - Once you disable the UI customization, you can duplicate the tab and remove the Developer console part to access the Home page.
- Or you can directly access the Setup by typing /admin at the end of your environment URL.
Eg: <CPQ Url>/admin - After logging into Setup, please fix the Main Menu template as per the instructions on this help documentation: MainMenu | SAP Help Portal
See Also
Keywords
ui customization, developer console, setup, main menu, breaking changes, home page, login, error , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ all versions