Symptom
Dynamic documents as email attachments are not sending.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Configure a business rule for dynamic document as email attachments
- Go to Email Services >> configure above rule in relative email template
- Email is triggered >> dynamic document is not sent
Cause
Cause 1: Email category/trigger used is not supported:
- Dynamic documents as attachment are generated during document flow; only email triggers under "(ONB) Document Flow Message Category" are supported:
- (ONB) Document Signature Declined Message To Participants Trigger
- (ONB) Document Signature task creation Trigger
- (ONB) Document Signature task creation for new hire Trigger
- (ONB) Document Signature task completion Trigger
- (ONB) Documents signed by New Hire Trigger
Cause 2: Incorrect PFS credentials configured in provisioning.
Cause 3: Incorrect business rule configuration.
Resolution
Scenario 1:
Workaround: Maintain the text in attachment document directly into email body instead and add email tokens (e.g. [[FullName]], etc.) as per business needs for dynamic email content.
(*Note: Email body has maximum length "4000".)
Scenario 2: 3353847 - [Onboarding] Dynamic document in email attachment not triggered - SAP for Me
- Go to Provisioning >> Company Settings
- Validate if PFS credentials configured is correct (e.g. URL with "/odata/PDF", user id & password is correct)
- If not, re-save the correct credentials in provisioning and test again
Scenario 3: 3401645 - [Onboarding] All dynamic attachments are not sent via email - SAP for Me
- Go to Admin Center >> Configure Business Rules
- Validate if document id configured in rule is correct
- If not, modify the business rule and test again
See Also
Keywords
SAP, SuccessFactors, Onboarding, Email Services, Dynamic Documents as Email Attachments, Business Rule , KBA , LOD-SF-OBX-EML , Notifications , Problem