Symptom
The value of the sales office and sales group in intercompany billing document is missing though the fields have been maintained properly in customer master data.
Environment
S/4HANA Cloud Public Edition
Reproducing the Issue
- Create the intercompany billing document;
- There is no value filled in sales office and sales group.
Cause
This is a standard behavior.
The information of the sales group and sales office can be used as a criterion within a sales process with sales activities. Due to the concept of billing, it is supposed to take over this information from the sales order into the billing document to the external customer only, because this process is a sales process with sales activities.
The internal invoice is usually not related to an internal sales process with sales activities. Usually the sales area for the internal invoice differs from the sales area for the external invoice. So the information of a sales group (sales office) would be usually wrong. As a result, this information is deleted in an intercompany process for the internal invoice.
Resolution
A workaround would be to have custom fields in the sales order and fill them with the sales group and the sales office. This would not fill the original fields but the information would be available.
The circumstances is relate to a consulting issue. The local developer and consulting team are the right people to go for.
2801299 - What is Support - What is Consulting.
See Also
2848851 - No Sales Office and Sales Group data in intercompany billing document
2801299 - What is Support - What is Consulting.
Keywords
Intercompany Billing; Sales Office; Sales group; VKBUR;VKGRP , KBA , SD-BIL-IV-2CL , Processing Billing Documents (Public Cloud) , Problem