Symptom
Block Calendar functionality is not working on the new Integrated Learning Experience page and redirects the user to a blank page instead of opening the Block Calendar pop-up.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Navigate to the New Learning Home Page
- Search for an item or curricula that has "Block Calendar" option on it
- Click on the option
- Notice that you are being redirected to a completely blank page in the browser, even though the expected behaviour would be that this pop-up appears for you:
Cause
ILX is loading incorrect CLDR data resulting in issues with the Calendar Picker functionality the pop-up would use.
Resolution
Engineering has identified the root cause and they are working on a fix for this issue for 2H 2024. We will update this KBA if there is a possibility to patch the fix earlier.
Keywords
block calendar, ILX, integrated learning experience, block, calendar, pop-up, blank, INC8975022, LRN-164568 , KBA , LOD-SF-LMS-ILX , Integrated Learning Experience , Known Error