Symptom
Time account validity and bookable end dates are not adjusted after performing hire date correction.
Environment
SuccessFactors Employee Central Time Management
Reproducing the Issue
- Hire an employee
- Perform hire date correction to update the employee start date to a later date
- Check that even though the Validity/Bookable start dates have been adjusted, the same is not true for end dates.
Cause
Flexible Start Date Rule referencing a field other than hire date. In such cases, if the referenced field (such as contract period, seniority date or service start date, for example) are updated, the dates of the account are not adjusted automatically.
The reason why the start date is adjusted and the end date is not, is that for new hires, the start date of the first account will be the same as the hire date regardless of the flexible account creation start date rule.
Resolution
In order to resolve this, it is required to adjust the time account type date reference for the Employee and Account manually, (the external code is set to <userid_time account type internal id>) and adjust the start date for the rehire period valid to the new hire date. After saving, the time accounts are adjusted automatically.
See Also
Keywords
KBA , LOD-SF-EC-TIM-TA , Time Accounts (TAT, TA, TAD) , Problem