Symptom
This article describes the issue when enabling the MS Teams integration option in Manage Recruiting Settings. If you navigate away from the page and then go back into "Manage Recruiting Settings," the option is not saved and is showing disabled.
All the configuration and permissions have been set up correctly as per the steps in the guide: Microsoft Teams Integration for Interview Scheduling.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to Admin Center > Manage Recruiting Settings.
- Under Interview Settings > Microsoft Integrations with Interview Scheduling, click on "Verify and Connect".
- You will receive the message saying "The verification is complete and you are successfully connected to Microsoft Exchange Online".
- Enable "Enable Microsoft Teams Integration" and click on Save.
- Navigate away from the page. Click on the top left-hand corner to go back to the Home page.
- Go back to Admin Center > Manage Recruiting Settings.
- Under the Interview Settings, notice that the "Enable Microsoft Teams Integration" is no longer ticked.
Cause
- Cause 1: General lack of permissions or missing configuration.
- Cause 2: The Admin outlook account (The Service account used in Work Tech Configuration and the Email Id used in the Outlook Integration settings) is not a local user in Microsoft Azure portal.
- Cause 3: The Admin outlook account's (The Service account used in Work Tech Configuration and the Email Id used in the Outlook Integration settings) calendar property: AllowedOnlineMeetingProviders (part of the Exchange Online MailboxCalendarConfiguration) is empty.
Note: This is even after you provide the account with the necessary permissions:
OnlineMeetings.Read.All
OnlineMeetings.ReadWrite.All
OnlineMeetingArtifact.Read.All
Observation: When SuccessFactors tries to establish a connection via MS Graph API to create online events on behalf of the service account with their application credentials, Microsoft responds with an "isOnlineMeeting": false value. Microsoft confirmed that some calendar properties are set up after the user's first usage of the calendar. This means, the service account has to be logged in and used (in any O365 application) before any connection with SuccessFactors can be made.
Resolution
- Resolution 1: Confirm the following configuration requirements.
- Make sure that your Admin outlook account (The Service account used in Work Tech Configuration and the Email Id used in the Outlook Integration settings) has the following permissions 1 and permissions 2.
- Admin Center > Set up Interview Scheduling Outlook Integration > Exchange Online configuration is completely populated with the correct credentials and endpoint. Test connection > Verify should be successful.
- Admin Center > Work Tech Configuration should be completely populated and enabled with the correct credentials. Connection Status should be Connected.
- Admin Center > Microsoft Integrations with Interview Scheduling > Validate your connection with Microsoft 365 using this option > Click on the Verify and Connect button. Connection should be established successfully.
- Resolution 2: Ensure that the Service Account email ID is created as a local user in Microsoft Azure Portal. The account user should have the same company email domain. For example, when employees have an email example@email-domain.com, then the Azure account setup by the customer's IT team should have the same domain, email-domain.com. If you need assistance on this part, please reach out to Microsoft Support.
- Resolution 3: The admin has to sign-in to any O365 application with the service account credentials (Outlook Web Access: https://outlook.office.com) and wait for the calendar properties to be updated. After this, the property "allowedOnlineMeetingProviders" should have changed to "teamsForBusiness" instead of being empty. If you need assistance on this part, please reach out to Microsoft Support.
After verifying all the configuration above, you can run an ODATA API Metadata Refresh from Admin Center and try enabling the option "Enable Microsoft Teams Integration".
See Also
Implementation Guide - Microsoft Teams Integration for Interview Scheduling
Keywords
Enable Microsoft Teams Integration, Microsoft Teams, Interview Scheduling, Outlook Integration, MS Teams Integration, MS toggle, not appearing, not visible, not saving, greyed out, RCM, Recruiting Management , KBA , LOD-SF-RCM-IVW , Interview Central, Interviews, Scheduling etc , Problem