Symptom
You are seeking to assign Surveys to specific Visits of an Account and are not able to achieve it with the Survey frequency "Always" or "Once".
Neither the Always or Once frequency match your business needs.
Example:
- You want a specific Survey to be answered only on specific Visits, such as a 'Store Check' and not all Visits of that same Account.
Environment
SAP Cloud for Customer
Cause
The "Always" frequency:
- Choosing Always allows the task to be generated in every applicable Visit, as defined by the Activity Plan and Routing Rules
The "Once" frequency:
- Allows the Survey to be completed only once per Account (regardless or how many Visits there are that match the criteria). It cannot be retriggered again to the same Account if it has been completed, irrespective of the Activity Plan or Routing Rule.
Resolution
A workaround can be used to trigger the Survey only in the specific Visits you choose to by using an extension field.
Please note: this Survey needs a dedicated Activity Plan and Routing Rule. Due to the extension field condition, do not use with other Surveys that you need to be answered Always (in every Visit of that Account). Use a different Activity Plan and Routing Rule for that Frequency.
Part one: adding an extension field to Visits TI
- Log in the system
- Go to Visits WC > Visits
- Open any Visit and Start Adaptation mode
- Right-click or select the header
- On the Adaptation Mode pane, click Add > Field
- Click on Create Field
- Give it a Label name and select Indicator type
- Default value should be off
- Save and close
- Select the Extension Field created and Apply
- End Adaptation Mode
You can use other type of Extension Field such as List, but Indicator is the recommended type that works best for this scenario.
Part two: setting up your Activity Plan
- Go to Activity Planner WC > Plans
- Create a new Activity Plan and include the Survey required
- Check "Assign Automatically"
- Check "Mandatory" if needed (optional)
- Frequency should be set to Always
- Save
Part three: setting up your Routing Rule
- Go to Activity Planner WC > Routing Rule
- Create a new Routing Rule
- Under "Conditions" click "Add Group"
- Select the same extension field you created previously
- Compare operator should be "Equal To" with "Value"
- Turn the Indicator (toggle) ON
- Click OK
- Add the Activity Plan you created previously
- Save
If you created a different type of Extension Field, such as List, add the value required to match the condition.
You can also add other information relevant to your business needs in the Activity Plan and Routing Rule, such Org Units or Accounts. This does not affect the workaround.
How to use the workaround:
- Open the Visit that you need this specific Survey to be assigned. Example: Store Check
- Edit the Visit and turn the Indicator (toggle button) ON and Save
- This will trigger the Routing Rule accordingly and the Survey will only get assigned to that Visit that matches the Extension Field condition
- The Survey will not get assigned to all Visits even with the Frequency 'Always' on, as it depends on the condition of the Extension Field to match.
- You can use this extension field to trigger the Survey to as many specific Visits as you wish.
With this workaround, you can control in which Visits and when the Survey gets assigned without assigning to all other Visits of the Account.
See Also
KBA 3096103 - Missing Surveys on Visits
KBA 3491375 - Random assignment of Surveys with frequency 'Once' in Visits
Keywords
KBA , LOD-CRM-ACT-VST , Visit Planning , LOD-CRM-ACT-ROT , Activity Routing , LOD-LE-SUR-DEF , Survey definition = design time , How To