Symptom
You have created a new Communication System in SAP Sales or Service Cloud Version 2 but for some reason, the system is not generating the respective Technical User for the Inbound Communication as it creates automatically.
Environment
SAP Sales Cloud Version 2
SAP Service Cloud Version 2
Reproducing the Issue
- Go to Settings
- Go to Integration
- Open the Communication System
- Create a New Communication System
- Define the System ID (Display ID)
You expect to create the Technical User automatically for the Inbound tab (e.g. User: Display ID Name).
Cause
You might have a missing authorization for the below Services on which the Communication User depends on.
Business Service: sap.crm.service.dataConnectorService (Data Connector Configurations)
It must be enabled to the respective Business Role for Business Service as well as assigned as Admin in the App List.
Resolution
- Go to Settings
- Go to All Settings
- Search by Business Roles
- Open the respective Business Role defined for the User you are logged on.
- For the App List, search by Data Connector Configurations
- Ensure you have the Admin option enabled as well as Enable App option checked in
See Also
In the Business Service option, also certify you have no restriction set for sap.crm.service.dataConnectorService for Read and/or Write.
Keywords
technical user;business role;communication system;user , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem