SAP Knowledge Base Article - Public

3506702 - PDI solution check items dump.

Symptom

When checking items in PDI solution check fails with below error.

HTTP 500 (internalServerError) - Dump or unhandled exception in backend.

Environment

  • SAP Cloud Applications Studio.
  • SAP Business ByDesign.
  • SAP Cloud for Customer.

Reproducing the Issue

  1. Login into Cloud Application Studio.
  2. Open PDI solution.
  3. Under Repository explorer right click on PDI solution.
  4. Check All Items.
  5. Check failed with below error.

     HTTP 500 (internalServerError) - Dump or unhandled exception in backend.

 

 

Cause

PDI solution being Huge.

Resolution

To perform the Check for huge Solution it is recommended to perform 'Enable Background Mode' and then do Solution Check.

1. Login to SDK.
2. Open Solution.
3. Right-click on the Solution in Solution Explorer.
4. Click on Check > Enable Background Mode.
5. You can perform the solution level check now.
6. To find the logs of the check you can click on 'Display Logs'.

Please note It may take hours to run the solution check as the solution is huge.

Keywords

PDI, http 500, Solution, huge, Enable Background Mode, Check items , KBA , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , Known Error

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions