SAP Knowledge Base Article - Public

3506842 - External Customer Invoice Request Inconsistent

Symptom

External Customer Invoice Request is inconsistent due to following error message:

Error: Sales data for product 123 missing for sales org. and distr. channel (Where 123 represents the Product or Service ID).

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Customer Invoicing work center
  2. Select Invoice Requests view
  3. In the drop-down menu, select All Invoice Requests
  4. Search for External Customer Invoice Request ABC (Where ABC represents the External Customer Invoice Request ID)
  5. Click in Check

The following error is shown:

Error: Sales data for product 123 missing for sales org. and distr. channel

Cause

The error "Sales data for product 123 missing for sales org. and distr. channel" might occur due to the following reasons:

  • The Service or Product ID are currently under status Blocked.
  • The Sales Organization and Distribution Channel under the Sales Tab in the Product/Service Master Data are under status Blocked.
  • The creation of the External Customer Invoice Request has occurred while one of the above options were set to Blocked.

Resolution

To solve this issue, please make sure that the status of the Product/Service ID are set to "Active" and the respective Sales Organization and Distribution Channel are also set to "Active" and correctly maintained under the Sales tab in the Product/Service Master Data.

Once the above data is correctly maintained, send an update to the payload by setting the Action Code as 2 or 4 so the system can clear the inconsistency in the UI.

Keywords

Webservice, Payload, error, not maintained, missing, invoice. , KBA , SRD-CRM-INV , Customer Invoicing , Problem

Product

SAP Business ByDesign all versions