SAP Knowledge Base Article - Public

3507025 - Error "Invalid time zone entered for date '', check your input" occurs at the service contract item level when defining prices

Symptom

Error "Invalid time zone entered for date '', check your input" occurs when clicking "Define Prices" and entering date in the field "End of Automatic Renewal" at the service contract item level.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the service contract and click into the item details.
  2. Check the flag for automatic renewal and enter the "Renewal Period" and "Contract Extension".
  3. Click on "Define Prices".
  4. In the pop-up screen, enter the date into the field "End of Automatic Renewal" and click "OK".
  5. Error "Invalid time zone entered for date '', check your input" occurs.

Cause

Due to that date type "AR_END" and duration "AR_NOTI" are necessay in the date profile when defining prices, this error will occur when date type "AR_END" or duration "AR_NOTI" is missing in the date profile being used.

Resolution

The solution is to do relevant adjustments in the below configuration activities:

  1. Add date type "AR_END" and duration "AR_NOTI" to the date profile in the configuration activity "Define Date Profile for Service Transactions (104301)".
  2. Assign the adjusted date profile to the service contract type in the configuration activity "Assign Date Profile to Transaction Types (104327)".
  3. Assign the adjusted date profile to the service contract item categories in the configuration activity "Assign Date Profile to Item Categories in Service (104328)".

Keywords

Error, Invalid time zone, Date, Check your input, Define prices, End of automatic renewal, Service contract, Item, Automatic renewal, Renewal period, Contract extension , KBA , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions