Symptom
When the employee or the administrator wants to create a new leave request, the system throws an error "No valid ad hoc account on DD.MM.YYYY" although the employee has a valid ad hoc account on DD.MM.YYYY.
Environment
SAP Business ByDesign
Reproducing the Issue
For an employee:
- Go to Home -> Self-Services.
- Click New leave request.
- Choose the date as DD.MM.YYYY.
- Input the mandatory information.
- Process until Confirmation.
For an administrator:
- Go to Time Administration -> Employees.
- Navigate to the issued Employee.
- Edit the employee's Time file.
- Add a row to in Employee Times tab.
- Choose the date as DD.MM.YYYY.
- Input the mandatory information.
- Save.
Cause
The used time type of leave request is linked to an ad hoc account in Special Posting Order. The linked ad hoc account can be checked in Special Posting Order of the Activity "Time Type" in Business Configuration. After assigning the ad hoc account, a change has been made in the planned working time i.e., work schedule.
When adding an ad hoc account to the time account balance or there was a change in the planned working time, employee times valuation run will get triggered automatically. If planned working time has changed, the system set valuation run start date to beginning of month or one week back, which will cause the currently ad hoc account ended one month or one week early.
Resolution
It is possible to book holiday on DD.MM.YYYY by deleting the issued ad hoc account from Time Account Balance and removing the issued ad hoc account from Time Account Rules in the employee's Time File, if employee owns other valid time account linked to the issued time type on DD.MM.YYYY.
Keywords
No valid ad hoc account, planned working time change, leave request, employee times valuation run , KBA , SRD-HR-TLM , Time and Labour Management , Problem