SAP Knowledge Base Article - Public

3507425 - Custom Fields Under Emergency Contact are Not Viewable Until Clicking on Edit Details

Symptom

  • Custom fields are not viewable until edit details clicked in emergency contact.
  • Custom fields under emergency contact will appear exclusively on the details edit page

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  • Go test user Primary Emergency Contact
  • Edit
  • Result: No Emergency Contact Custom String 1
  • Then
  • Click on edit detail
  • Result:  Emergency Contact Custom String 1 display

Cause

This is expected behavior

Resolution

This is expected behavior

  • On the quick edit page, only the following 8 fields will be displayed if they are enabled in BCUI(emergencyContactPrimary):
  • FieldName: Name, relationship, primaryPhone, email, isEmergencyContact, isDependent, primaryFlag, secondPhone.
  • All other fields configured in BCUI will appear exclusively on the details edit page.

FAQ - Additional Information

Q) Where can I get information on this from the Guide?

A) Guide: Data Model Field Information for Employee Central 

                                                                                                                                           

Keywords

INC9160548 , Edit Details,  Name, relationship, primaryPhone, email, isEmergencyContact, isDependent, primaryFlag, secondPhone, custom , KBA , LOD-SF-EC-PER-ECO , Emergency Contact Details , Problem

Product

SAP SuccessFactors HCM Core 2405