Symptom
- For future hire, if an user has both personal and business address, update of Business address won't get updated to EP by HRIS sync job. ( it's working for real-time sync)
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HCM Suite
- SAP SuccessFactors Employee Central
- SAP SuccessFactors SFAPI
Reproducing the Issue
- Hire user
- Update User Email address Via API
- email address sync to EC
- Email address not sync to EP
Note:( View Guide Chapter - Employee Central Data Import or API Operations-
- An HRIS Sync job that is triggered by data import or API operations does not start immediately.
- Instead, it waits a maximum of 10 minutes before starting. Only one HRIS Sync job can run at a time.
Cause
- This is considered as a defect in 2405 release
- Code issue only date effective type data has future records and The logic needs to be corrected
Resolution
This is considered as a defect in 2405 release and Our engineering team has submitted a fix which was scheduled to be released in 2405P17:
A fix for this issue is currently planned via a patch 2405p17 (13-Aug-24 Preview)
Patch Reference: PTCH-44598
- Preview - 13th August 2024
- Production - 15th August 2024
See Also
- 2080728 - Employee Central: What is HRIS Sync?
- 2080813 - HRIS Sync: Import & API upsert considerations - Employee Central
- 3379950 - 2H 2023: Enhanced Execution of HRIS Sync Jobs Triggered by Data Import or API Operations
- Guide Chapter - Employee Central Data Import or API Operations
Keywords
PTCH-44598, INC8997197, ECT-240318, API, future hire employee, ONB, email address, personal infos, real-time sync, hris sync , KBA , LOD-SF-EC-HRS , HRIS Sync , LOD-SF-INT-API , API & Adhoc API Framework , Known Error