SAP Knowledge Base Article - Public

3508481 - Candidates are not receiving Email Campaigns - Recruiting Marketing

Symptom

Candidates are not receiving Email Campaigns.

Environment

  • SAP SuccessFactors Recruiting Management
  • SAP SuccessFactors Recruiting Marketing

Cause

This problem can be due to different causes.

  • Cause 1: The candidate has not enabled "Hear more about career opportunities".
  • Cause 2: The Reply-To Email Address for the Email Campaign has a custom email domain.

Resolution

For the cause 1:

Email campaigns are sent to candidates who have opt-in to Consent to Marketing option "Hear more about career opportunities" when creating their accounts or within their candidate profiles.

Recruiting users can view the option on the candidate profile page. Refer to the following KBAs for details.

  • 2600243 - About the Notification Options on the Candidate Account Creation Page - Recruiting
  • 2907586 - What does each Marketing Consent checkbox in Candidate Profile mean? - Recruiting Management

It is possible to report on the option and update it on behalf of the candidate using Integration Center. Please refer to the KBA 3082108.

For the cause 2:

It is necessary to update the DNS settings to allow RMK to send campaign emails using a custom Reply-To email address.

Please refer to the following KBAs:

  • 3458980 - How to Change the Reply-To Email Address for Email Campaign - Recruiting Marketing 
  • 2934054 - CRM - Change/alter the Sender Email Address and the Reply-To Email Address for Email Campaigns - Recruiting Marketing  

See Also

  • 2600243 - About the Notification Options on the Candidate Account Creation Page - Recruiting
  • 2907586 - What does each Marketing Consent checkbox in Candidate Profile mean? - Recruiting Management
  • 3082108 - How to update / report on Consent to Marketing or "Hear more about career opportunities" option via Integration Center - Recruiting Management
  • 3458980 - How to Change the Reply-To Email Address for Email Campaign - Recruiting Marketing 
  • 2934054 - CRM - Change/alter the Sender Email Address and the Reply-To Email Address for Email Campaigns - Recruiting Marketing

Keywords

not receive, email campaign, Consent to Marketing, Hear more about career opportunities, Reply-To, SPF, DNS , KBA , LOD-SF-RMK-CRM , Data Capture Form, Email Layout, Email Campaign , LOD-SF-RCM-CRM , Candidate Relationship Management , Problem

Product

SAP SuccessFactors Recruiting all versions