Symptom
When user is requesting a "User extended file", some of the entries show duplicated in the file for specific users.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Go to "Export Extended User Information"
- Select "Valid users only"
- Then click on "Export extended data"
- Download the file when it's ready
- See duplicated entries for some users
Cause
The issue is due to the legacy design, user id is not a unique key in personal info data. When customer has multiple import/UI insert/api insert on personal info data at the same time, there is a small chance that both data will be saved under same user id when data creation.
Resolution
The unique key will be applied in 2H 2024 release (Preview October 19-20, Production Nov 16-17) in order to prevent the issue. As well as a check tool script option to clear the duplicated records from the front end.
Until the release, you can raise a ticket under LOD-SF-PLT-UIM component so engineering team can remove those duplicated records.
Keywords
INC8769567, duplicate, extended, file, user, duplicated records, sf, successfactors. , KBA , LOD-SF-PLT-UIM , Employee Import Issues , Problem