Symptom
On clicking 'Cancel' action, Ticket field changes are saved after sending Interactions.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
- Go to Service Work Center.
- Go to Ticket Work Center view.
- Open Ticket 123(where 123 is the ID of the Ticket).
- Change any field value in the ticket header(Example- Status).
- Now, go to Interaction/Timeline facet.
- Create an E-mail or any Interaction and click on Send.
- Click on the Cancel button.
Notice that even on performing 'Cancel' action on ticket, the field changes are saved.
Cause
When an Interaction is created, an automatic Save action is triggered(to link the Interaction with the corresponding Ticket).
Resolution
This is the current expected behavior of the system.
Keywords
Interaction, Timeline, Ticket, Save, Cancel. , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SC-EML , Email , LOD-CRM-SRP-INT , Ticket Interactions , Problem
Product
SAP Cloud for Customer core applications all versions