SAP Knowledge Base Article - Public

3509070 - Ticket Change are Saved Despite Cancelling

Symptom

When you make changes to a ticket, then send an interaction but then click on Cancel, the previous ticket changes are saved anyway. 

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the work center Service, view Tickets.
  2. Open a ticket and go into Edit mode.
  3. Change a change, e.g. change the priority.
  4. Go to the Interactions tab and click on New for a new email for example.
  5. Write and email and click Send.
  6. When the email popup disappears, click Cancel.
  7. Despite cancelling the action, the change to the ticket priority is still being saved.

Cause

A save is triggered when you send an email from a ticket. This is necessary in order to save and thread the email to the ticket.

Resolution

It is correct that any changes made before sending an email will also be saved. You will also receive the info messages in the ticket:

Your entries have been saved.
Email sent successfully.
 
If you would like to request a change in behavior, please make use of the Influence forum available on 

https://influence.sap.com/sap/ino/#/campaign/1867

Keywords

ticket, service, change, edit, change, save, cancel, email, interaction , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer core applications 2408