Symptom
When you make changes to a ticket, then send an interaction but then click on Cancel, the previous ticket changes are saved anyway.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the work center Service, view Tickets.
- Open a ticket and go into Edit mode.
- Change a change, e.g. change the priority.
- Go to the Interactions tab and click on New for a new email for example.
- Write and email and click Send.
- When the email popup disappears, click Cancel.
- Despite cancelling the action, the change to the ticket priority is still being saved.
Cause
A save is triggered when you send an email from a ticket. This is necessary in order to save and thread the email to the ticket.
Resolution
It is correct that any changes made before sending an email will also be saved. You will also receive the info messages in the ticket:
Your entries have been saved.
Email sent successfully.
If you would like to request a change in behavior, please make use of the Influence forum available on
Keywords
ticket, service, change, edit, change, save, cancel, email, interaction , KBA , LOD-CRM-SRP , Service Request Processing , How To
Product
SAP Cloud for Customer core applications 2408
SAP Knowledge Base Article - Public