Symptom
Error occurs when user tries to create a new Service Order from Inbound Phone Call.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Simulate an Inbound Call to the system.
- Confirm the relevant Customer or Contact.
- In the Customer Hub Detail view screen, click on 'Create' and select Service Order.
- Fill in all the required details and click on Save.
Notice that error occurs - "The provided reference source type is not supported".
Cause
The create with reference is allowed only from case perspective. So, Service order can be created as a follow up to a case and not to a phone call. It can also be created for an Account from Agent Desktop.
Resolution
This is the current behavior of the system.
As an alternative, you can raise an idea in the Influence Portal using the below link:
SAP Sales and Service Cloud Version 2 & SAP Enterprise Service Management
Keywords
Service Order, Phone Call, Error, Source Type, Agent Desktop, Inbound , KBA , CEC-CRM-SRVO , Service Order for SAP Sales/Service Cloud , CEC-CRM-AD , Agent desktop - live channels , CEC-CRM-PH , Phone Calls for SAP Sales/Service Cloud , Problem