Symptom
The following error occurs when entering a Service into a Sales Order:
Item XX: Products with item group External Service – Time and Material not supported
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the Sales Orders view.
- Click on New and select Sales Order.
- Enter the respective account.
- Navigate to the Items tab.
- Add Service XYZ (XYZ represents the Service ID).
- The following error message occurs:
Item XX: Products with item group External Service – Time and Material not supported
Cause
The item group RSTM - External Service – Time and Material is used as a place holder in Service Orders for Services that are requested but yet to be defined. The requested Service Item is replaced by concrete Services and Materials by the Service provider through planning, processing, reporting back, and invoicing the requested service.
This item group is only supported in the Service scenario (Service Orders) and not in the Sales scenario (Sales Order).
Resolution
This is the expected system behaviour.
See Also
Further information on item types can be found in the Help Center Document Services
KBA 3216002 - Error: Item XX: Products with item group XYZ not supported
KBA 3509521- Error: 'Products with item group External Service – Time and Material not supported' Occurs When Entering a Service into a Service Order
Keywords
RSTM; Service; item type; item group; time and material; external service; not supported; sales order; quote; , KBA , AP-SLO-SO , Sales Order , Problem