Symptom
The following error occurs when entering a Service into a Service Order:
Item XX: Products with item group External Service – Time and Material not supported
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Service Orders work center.
- Select the Service Order Processing view.
- Click on New and select Service Order.
- Enter the respective account.
- Navigate to the Items tab.
- Add Service XYZ (XYZ represents the Service ID).
- The following error message occurs:
Item XX: Products with item group External Service – Time and Material not supported
Cause
In order to use the item type RSTM - External Service – Time and Material in a Service Order the following scoping question needs to be answered with Yes:
Do you want to integrate with purchasing processes for externally fulfilled service and expense items in service orders?
Resolution
You can find the scoping question as follows:
- Go to the Business Configuration work center.
- Go to Implementation Projects view.
- Select the implementation project and click Edit Project Scope.
- Go to the step Questions.
- Expand the following elements:
- Service -> Service and Repair -> Service Order
- In the section Third Party Field Service and Repair the respective question is: Do you want to integrate with purchasing processes for externally fulfilled service and expense items in service orders?
See Also
Keywords
RSTM; Service; item type; item group; time and material; external service; not supported; , KBA , AP-SVO-SO , Service Order , How To