SAP Knowledge Base Article - Public

3509638 - Unable to Train Ticket Categorization Model in C4C

Symptom

When training the model for Ticket Categorization model the below error occurs:

Save training failed, model training failed.

Environment

  • SAP Cloud for Customer

Reproducing the Issue

  1. Go to administrator work center > Prediction Services.
  2. Click on model setup.
  3. Select Ticket Categorization.
  4. Select the model you wish to activate.
  5. Click on train.
  6. Error occurs: "save training failed, model training failed".

Cause

The csv file being used for the model is not up to date with the latest service category catalog.

You can check what service catalog to use by navigating to Administrator > Service and Social > Service categories.

Resolution

Please ensure that when you update the catalog that you train a new model to be able to use the new catalog. Please also ensure that you are using a clean CSV file with no empty rows.

You can refer to the following guide for more information on this. 
 

Keywords

 Ticket Categorization, Machine Learning, AI, Prediction Services, Service Categories, save training failed, model training failed , KBA , LOD-CRM-ML , C4C Machine Learning , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions