Symptom
When creating a Case via API POST request, The status is defaulted to Draft on the Service Cloud V2 UI.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2 1.0
Reproducing the Issue
- Open an API Development Platform e.g Insomnia, Postman
- Create a Post request to Create a Case (https://<TenatURL>/sap/c4c/api/v1/case-service/cases)
- In the Body of the request, set the status to anything other than Open or Draft. e.g Completed.
- Send the request.
- The Case is Created on the SCV2 UI with status "Draft".
Cause
If the status provided is anything other than Open or Draft(if it exists in status schema) , then the status defaults to the initial status.
Resolution
This is the current expected behaviour.
Keywords
API, Case, Status, Draft, Open, POST, Service Cloud V2, , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0
SAP Knowledge Base Article - Public