Symptom
When the user attempts to delete a question from Question Library, the question continues to appear in the UI after refreshing the page.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Open "Question Libraries".
- Open any question library and select question to delete.
- After deleting the question and refresh the page, the question continues to appear in the UI.
Cause
It is because of a data issue. There could possibly be more Child Questions associated to the Question being deleted.
Resolution
- This issue occurs when there is data issue with a cascading question.
- The UI only shows only one question, but there may be other child questions associated with the parent question in the database.
- To view all the child questions, the question library needs to be downloaded.
- To resolve the issue and delete the questions, the engineering team needs to execute a DB script after receiving customer approval.
- If you are experiencing this behavior, please raise a ticket to Product Support and refer the question affected.
Keywords
question library, cascading question, delete question, delete question library, delete cascading question, recruiting management, "Failed to remove Competency", “is not authorized to access activity”, "com.successfactors.competency.service.RemoveCompetency", INC8451044, INC9192641 , KBA , LOD-SF-RCM-ADM , Admin Center, RBP, Permissions and Settings , LOD-SF-RCM , Recruiting Management , Problem