Symptom
When you try to access embedded SAC in chrome browser, the stories does not load. It gives the below error message.
"Cannot connect to the model. Please verify that you have set the correct connection details for this model, then try again.
Model: xxxxxxxxxxxxxxxxxxxxxxxxxx
Model: xxxxxxxxxxxxxxxxxxxxxxxxxx
Correlation ID: ###########################"
But embedded SAC is accessible in other browsers like Edge, Firefox Etc.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Login to the system using SSO credentials.
- Navigate to Analytical Stories.
- Open any story.
- You will get the error message.
- Follow the above steps in a different browser.
- The stories will load and show data without any error messages.
Cause
Third party cookies are blocked in the Browser settings.
Resolution
Third Party Cookies must be allowed in the browser settings to embedded SAC in Chrome.
Execute below steps to allow Third party cookies:-
- In your browser, top right corner, click on (...) Settings and more.
- Navigate to Settings.
- Search for Cookies and site permissions.
- Click on Manage and delete cookies and site data.
- Disable the toggle button for Block third-party cookies.
Keywords
Browser, Cookies, Chrome, Edge, Not working, Not accessible, Blocked, Connection Details, Model, Cannot connect, embedded SAC , Not enabled, Settings, Browser settings. , KBA , CEC-CRM-ANA , Analytics for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0