Symptom
The contact person number is missing in the Maintain Business Partner App.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open a BP in the Maintain Business Partner app.
- Navigate to the relationship section.
- A contact person is listed but the contact person number field is blank.
Cause
The contact person field is specific to the Customer or Supplier Contact Person and becomes visible once in the Customer or Supplier role. This value will not appear while viewing the BP in the default BP role, since the value is specific to Customer or Supplier roles.
Resolution
- Open a BP in the Maintain Business Partner app.
- Select a customer or supplier role
- Navigate to the relationship section.
- The contact person number field is filled.
Keywords
S4_PC, S4_1C, S/4HANA Cloud, SAP S/4HANA Cloud Public Edition, Contact Person, CP, KNVK-PARNR, PARNR, Maintain Business Partner , KBA , LO-MD-BP , Business Partners , Problem
Product
SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions