Symptom
When creating a Standard Filter Field in Manage Templates, the Picklist ID field doesn't show up.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Recruiting Management
Cause
This is an expected behavior when creating a new Standard Filter field.
Resolution
All details from a Filter field must be maintained in Internal and External Career Search Settings for both External and Internal portals.
After defining the Label, Picklist and Parent Picklist (If applicable), the User will need to define the field in the Job Requisition. At this moment, the Picklist field won't appear, which is expected. The User will save the new Field without providing the Picklist ID. Then, after a couple of minutes and refreshing the page, the User will see that the Picklist ID now appears with the Picklist ID already populated with the value configured on Internal and External Career Search Settings.
Keywords
filter, field, picklist, manage, templates, missing, see, cannot , KBA , LOD-SF-RCM , Recruiting Management , LOD-SF-RCM-JOB , Job Postings & Requisitions , Problem