Symptom
IAS/IPS User Sync from Successfactors is failing due to Email Address data is not updated in UDF or User entity for the Future Hire employees
Disclaimer: Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- Integrations
- SCIM API/ ODATA API
- Integrations
Cause
The Business Email Address sync from Email Information portlet to User entity for future Hire Onboardee Employee was not getting updated with HRIS sync job. Also we cannot directly update the Onboardee Employee data via API, as create or edit external users through the User entity is not supported.
KBA-2994898 - Unable to upsert/insert external users in the User entity
Resolution
Create an SAP Case and we will create an internal Incident with the Engineering team to validate the HRIS sync issue.
See Also
Keywords
SCIM, API, IAS/IPS, User sync, Email Address, External User, Sync, Future Hire, sync , KBA , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT-INC-ODATA , ODATA API In Integration Center , LOD-SF-INT-INC-JOB , Integration Center Job , LOD-SF-INT-ODATA , OData API Framework , Problem