SAP Knowledge Base Article - Public

3512290 - IAS/IPS User sync from Successfactors in falling due to Email Address data is not updated in UDF(User entity)

Symptom

IAS/IPS User Sync from Successfactors is failing due to Email Address data is not updated in UDF or User entity for the Future Hire employees


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Environment

  • SAP SuccessFactors HXM Suite
    • Integrations
      • SCIM API/ ODATA API

Cause

The Business Email Address sync from Email Information portlet to User entity for future Hire Onboardee Employee was not getting updated with HRIS sync job. Also we cannot directly update the Onboardee Employee data via API, as create or edit external users through the User entity is not supported. 

KBA-2994898 - Unable to upsert/insert external users in the User entity 

Resolution

Create an SAP Case and we will create an internal Incident with the Engineering team to validate the HRIS sync issue.

See Also

KBA-2994898 - Unable to upsert/insert external users in the User entity 

Keywords

SCIM, API, IAS/IPS, User sync, Email Address, External User, Sync, Future Hire, sync , KBA , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT-INC-ODATA , ODATA API In Integration Center , LOD-SF-INT-INC-JOB , Integration Center Job , LOD-SF-INT-ODATA , OData API Framework , Problem

Product

SAP SuccessFactors HCM Core 2405 ; SAP SuccessFactors HCM Suite 2405