Symptom
In visit, Survey "Last Response Date/Time" value is not available, after finishing the survey.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite:
- An Account ABS has a visit with multiple Surveys, where ABS represents Account ID.
- This visit has two surveys ID XXXX and YYYY, where XXXX and YYYY stands for two different the Survey ID. These surveys are enabled with "Previous answer" field.
- Last response date is available only when the survey is enabled for previous answers.
- Visit Type should be same.
Steps to reproduce :-
- Go to Visits work centre.
- Go to Visits work centre view.
- Search and Open any Visit.
- Click on the Check-in button.
- Go to Survey facet.
- Click on Survey XXXX link.
- Answer the questions and finish the Survey.
- Field "Last Response Date/Time" value is blank.
- Click on Check-out button.
Expectation: Last Response Date/Time value available as the date of last survey done.
Cause
Visit Survey, "Last Response Date/Time" Value Is Blank, as this is the first visit created for an account.
Resolution
Complete the survey XXXX for a Visit (first visit) for an Account ABS. When this survey is executed for the visit for the first time, Survey "Last Response Date/Time" is blank. This is an expected behavior.
When a new visit (2nd Visit) is created for an Account ABS with the survey XXXX, which has "Previous answer" enabled, the field "Last Response Date/Time" has the date value shown. This date value which is the date of completion of survey XXXX as in immediate last completed visit of the visit survey completed.
Keywords
C4C, Surveys, Visits, Last Response Date/Time, Activities, , KBA , LOD-CRM-ACT , Activities , LOD-LE-SUR , Survey , LOD-CRM-ACT-VST , Visit Planning , How To