Symptom
When creating a Point-of-Sales Transaction the Sales Transaction is Inconsistent with the following error: Sales Item ABC-1: Product XYZ has insufficient Stock in Logistic Area EFG.
- ABC represents the Internal ID of Sales Transaction and 1 represents the Internal Item ID of the Sales Transaction.
- XYZ represents the Product ID.
- EFG represents the Logistics Area ID.
The Point-of-Sales Transaction is not posted to Accounting and no Goods and Activity Confirmation is created.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Select the Point-of-Sales Transaction view and the Sales Transactions sub view.
- Select the Sales Transaction ABC.
- The Status is Inconsistent.
- Click on the Check button.
- The following error occurs: Sales Item ABC-1: Product XYZ has insufficient Stock in Logistic Area EFG.
Cause
Product XYZ has No Negative Stock Allowed and the quantity for Product XYZ and Logistics Area EFG in Point-of-Sales Transaction ABC-1 exceeds the quantity available in stock in Logistics Area EFG.
With Release 2411 we introduced a validation check on the quantity for Products which do not have the negative inventory allowed in the respective Logistics Area.
When the Point-of-Sales Transactions is created the system validates if there is sufficient stock for the products available in Logistic Area which is passed in the payload under the element Logistics Area ID via the web service.
Scenario 1:
You create a Point-of-Sales Transaction for different Products that have No for Negative Stock Allowed maintained in the Logistics Area ID.
The system will check if the quantity maintained for the Product is available in the Logistics Area ID.
Scenario 2:
You create a Point-of-Sales Transaction for multiple Items with the same Product ID for a Material that has No for Negative Stock Allowed maintained in the Logistics Area ID.
The system will add the quantity of the Items with the same Product ID and the same Logistics Area ID and check if the combined quantity is available in the On-Hand Stock for this Logistics Area ID.
You can check if No is maintained for Negative Stock Allowed as follows:
- Go to the Customer Invoicing work center.
- Select the Point-of-Sales Transaction view and the Sales Transactions sub view.
- Open the Sales Transaction ABC.
- Navigate to the Sales Items tab.
- Select the Internal Item ID 1 and double click on the Logistic Area ID hyperlink (if this field is not visible you can make it visible via Personalization).
- You can see that the Negative Stock Allowed is maintained as No.
- In the General Data section, you can check the field Negative Stock Allowed.
- If this is set to No the system will validate if there is sufficient stock.
You can check the available quantity and as follows:
- Go to the Supply Planning work center.
- In the Common Tasks select Stock Overview.
- Enter the Product ID ABC and the Logistics Area ID EFG and click on Go.
- In the column On-Hand Stock you can see that the quantity is less than the quantity in the Sales Transaction.
Resolution
To solve the issue, you need to ensure that the On-Hand Stock equals or is greater than the quantity in the Sales Transaction in the Logistics Area ID.
Once you increased your stock accordingly you can perform the following steps:
- Go to the Customer Invoicing work center.
- Select the Point-of-Sales Transaction view and the Sales Transactions sub view.
- Select the Sales Transaction ABC.
- Click on the Check button.
The document will become consistent, and the Release button will be enabled.
Please note: You can also select multiple Sales Transactions and click on the Check button to make multiple documents consistent.
Keywords
Logistic Area; Stock; Quantity; Inconsistent; Point of Sales; POS; Transaction; insufficient Stock , KBA , AP-POS-POS , Point-of-Sale Transaction , Problem