SAP Knowledge Base Article - Public

3513089 - Business User Unable To Change Language In C4C App Using Ipad When Logged In Via SSO

Symptom

Business user is unable to change language in c4c app using Ipad.

Environment

SAP Cloud for Customer 

Reproducing the Issue

1. Login to C4C App on Ipad via.

2. In the settings Tab change to language to desired Language and save it.

3. Notice that when logged again the language is reverted back to the old one.

Cause

User logged in via SSO then the browser or system language is going to get picked irrespective of preferred language being maintained in the settings. 

Resolution

This is an expected system behavior.

Keywords

Ipad, Language settings, SSO , KBA , AP-RC-MOB-UIF , Responsive UI , Problem

Product

SAP Cloud for Customer core applications all versions