SAP Knowledge Base Article - Public

3513226 - Error - Personnel number xxxxxxx does not exist or you do not have authorization

Symptom

When trying to book time using API 'API_MANAGE_WORKFORCE_TIMESHEET' for an employee the following error occurs;

"Personnel number xxxxxxx does not exist or you do not have authorization".

Environment

SAP S/4HANA Cloud Public Edition

Cause

Employee is not active during the posted period. 

The  following CDS view I_PersonWorkAgrmtStatus can be used to check the work Agreement status of an employee.

Resolution

Ensure the timesheet date in the payload is within the active employment period of the employee.

See Also

API_MANAGE_WORKFORCE_TIMESHEET

Keywords

Personnel number xxxxxxx does not exist or you do not have authorization, API_MANAGE_WORKFORCE_TIMESHEET, Post, Error,TimeSheetEntryCollection. , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions