Symptom
Service Order is still visible under Field Service and Repair - Order Pipeline View, even if the execution status for each item is Finished or Release Cancelled.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Field Service and Repair Work Center.
- Navigate to Order Pipeline View.
- Select Option All Orders to be Executed.
- Search for the Service Order, then the record can be found. You can see the Service Order is in status In Process.
- Select the record and go to Services and Spare Parts Tab under the view, you understand that the execution status for each item is Finished or Release Cancelled.
Cause
If a Service Order is still in the "In Process" status, it will continue to be shown in the Order Pipeline under the following conditions:
- The Delivery Status of the Item is not "Finished"
- The Status of the Service Order is not "Completed"
Therefore, if an item is cancelled in a Service Order, the Delivery Status will be "Not Started" and the Service Order will still be displayed in the Order Pipeline.
Resolution
The Service Order with the cancelled item will be removed from the Order Pipeline View only when the Service Order has the "Completed" status at the header level. This is the expected system behavior.
See Also
3364624 - Service Order status in Order Pipeline View of Field and Service Repair work center is not as expected
Keywords
Service Order, Order Pipeline, Release, Cancelled, Delivery Status , KBA , AP-SVO , Service Order Processing , How To