SAP Knowledge Base Article - Public

3513362 - SystemUnenrollmentNotification Triggered when Registration Status Changed to 'NOT ATTENDED'

Symptom

The SystemUnenrollmentNotification is triggered when the user's registration status is changed to 'NOT ATTENDED'.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Learning

Cause

SystemUnenrollmentNotification will be triggered when user's Registration Status is changed to a 'Cancelled'  registration type.

In Learning Administration > Reference > Learning Activities > Registration Status screen, each Registration Status needs to set a registration type among  'ENROLLED' , "Waitlisted' , 'Cancelled' or 'Pending'.

Registration Status 'NOT ATTENDED' is configured as a 'Cancelled' Registration Type and hence triggered SystemUnenrollmentNotification.

Resolution

  • This is an expected behavior. Changing the Registration Type of 'NOT ATTENDED' to other types could trigger other Class notifications.
  • The SystemUnenrollmentNotification template can be modified to avoid user confusion.

See Also

Template ID to Trigger to Receiver Map

Keywords

SystemUnenrollmentNotification, Registration Status, NOT ATTENDED, Cancelled Registration Type, Class notifications. , KBA , LOD-SF-LMS-SCH , Class - Scheduled Offerings , Problem

Product

SAP SuccessFactors Learning all versions