Symptom
After applying the Code List Restriction (CLR), it's only working for users that have ADMIN role, for any other user, or admins with different layouts, the CLR didn't work.
Environment
SAP Sales Cloud Version 2
SAP Service Cloud Version 2
Reproducing the Issue
1. Login as the user affected.
2. Go to the entity which the CLR is set.
Result: The CLR is not restricting the values properly.
Cause
The user is assigned to a business role that has restricted access (read and/or write) to the entity services where the CLR is located.
Resolution
To ensure that a Code List Restrict works properly, the user cannot have any restriction for the entity where the CLR is located. So, in the Business Role configured for the user, all the entity access should be set as "Unrestricted".
Keywords
Code List Restriction, Admin, Restricted, Access, CLR, Unrestricted , KBA , CEC-CRM-CLR , Code List Restrictions for SAP Sales/Service Cloud , Problem