Symptom
The last approver receives the error "The pay component integration failed, and the claim wasn't saved. Please contact your administrator to check if the pay component configurations are enabled" during the claim workflow approval.
Environment
SAP SuccessFactors - Employee Central
Reproducing the Issue
- Proxy as the approver user;
- Open the affected workflow;
- Click to approve;
- Error message is thrown.
Cause
This error message is normally related to wrong configuration that leads to errors. Most common reasons are:
- The Pay Component is not associated to the Country/Region value;
- There is a rule triggering a message with severity 'ERROR' while approving the workflow, which can stop the pay component integration from being processed, leading to the error. You can use the Rule trace feature (2257064) to check if this is the case;
- In "Manage Business Configuration" > "One Time Payment" (payComponentNonRecurring) there is a Mandatory Field which is not used in the Claim Process.
Resolution
- Add the Pay Component in the Country record;
- Disable or adjust the configuration of the rule triggering the error message at the workflow approval;
- Check which fields are mandatory in "One Time Payment" (payComponentNonRecurring) and make it as Not Mandatory. We recommend only the fields 'Issue Date', 'Type', 'Value' and 'Currency Code' to be mandatory for this HIRS element.
See Also
3381811 - onSave rules triggered in payComponentNonRecurring when payComponent is created via benefit claim in 1H 2024
Keywords
EMPFILE_HRIS_ERROR_INVALID_ASSOCIATION_VALUE, BENEFITS_GO_BENEFIT_CLAIM_PAYROLL_FAIL, pay component integration failed, claim not saved, approval error, workflow error, claim request, "is a required field and cannot be blank", "ECT_service_layer_REQUIRED_FIELD_EMPTY" , KBA , LOD-SF-EC-GBF , Global Benefits , Problem