SAP Knowledge Base Article - Public

3513768 - Unable to Assign the Service Quote Approval Task to a User

Symptom

System not showing the user while trying to manually assign the service quote approval task.  

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Application and User Management work center.
  2. Go to the Task Distribution view.
  3. Go to the Business Task Management sub view.
  4. Select the approval task for Service Quote ABC (ABC represents the Service Quote ID)
  5. Click on Assign Item button
  6. Search for the User XYZ (XYZ represents the Business User ID)

System shows No Record Found

Cause

The approver does not have the necessary Read and Write accesses to approve the Service Quote ABC created with the Service unit DEF (DEF represents the ID of the Service Unit).

Resolution

You can assign the work center view CRM_OPP_SRVQUO to the employee XYZ  using the following steps;

  1. Go to the Application and User Management work center.
  2. Select the Business Users view.
  3. Select the user XYZ .
  4. Click on the Edit button and select the  Access Rights option.
  5. Navigate to Work Center and View Assignment tab.
  6. Assign the work center view CRM_OPP_SRVQUO  to this user.
  7. Navigate to Access Restrictions tab.
  8. For CRM_OPP_SRVQUO, ensure that both Read Access and Write Access are enabled for the corresponding service unit.
  9. Save your changes.

See Also

KBA 2258753 - Employee Does not Appear in the Direct Approvers List of the Sales Quote or Sales Order Approval Process

Keywords

Manual task assignment, task unassigned,  , KBA , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign all versions