Symptom
When using SAP S/4HANA Cloud Public Edition, it's found that some applications are set to the UTC time zone, while others are set to the user-specific time zone or organization structure (example plant as physical location) specific time zone.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
Check time stamps in different applications. For example, Create Billing Documents, Manage Sales Orders or Create Sales Order – VA01.
Cause
This is a standard system design and not a system error. While there are different time stamps in user-specific application displays (SAP Fiori, SAP WebDynpro, SAP Harmonized WebGui, etc.), the system uses UTC as the main operating system time zone. UTC is the official time zone used in all SAP public cloud applications, including SAP S/4HANA Cloud Public Edition, to help our customers managing global businesses across time zones.
UTC is also the time zone used to provide upgrades and maintenance to the system independent of location and data center. UTC helps harmonize upgrade and maintenance activities for thousands of SAP S/4HANA Cloud Public Edition systems in shared environments (shared environments might include customers in different time zones).
Resolution
The operating system time zone in SAP cannot be changed from UTC, as doing so would interfere with system operations such as upgrades and maintenance.
SAP currently offers different user interface applications through the SAP Fiori Launchpad, including SAP Fiori, SAP Webdynpro, and SAP Harmonized WebGui. Some applications allow users to showcase time in their own time zone (SAP Fiori & SAP Webdynpro in most cases), while others display time in UTC (WebGui in most cases). SAP plans to transition most applications to SAP Fiori in the future, where customers will have the option to display time in their own time zone based on their settings in the "Language and Region" section (when applicable). New applications will come with this feature by default (when applicable).
In SAP S/4HANA Cloud Public Edition, applications like Production follow the specific plant time zone as per business requirements, meaning that time stamps are allocated based on the location where the production took place.
Integrations, such as EDI, are recommended to be managed in UTC time zone to standardize. Translations of time zones should be performed at the receiving application. Other specific business requirements (send EDI in user local time) may necessitate the use of cloud extensibility during implementation to address them (transform time zone in middleware).
See Also
- 2716344 - Timezone in Cloud system is set to UTC as default - SAP for Me
- 3480071 - Billing Document Creation Time needs to save and display in a non-UTC time zone - SAP S/4HANA Cloud - SAP for Me
- 2825498 - Planned Maintenance Timelines for S/4HANA Public Cloud and Marketing Cloud System - SAP for Me
- 2850054 - Sales Order change/create times are unclear - SAP for Me
- 2892513 - How to set billing date equal to billing creation date via copy control - SAP S/4HANA Cloud Public Edition - SAP for Me
- 3514640 - Enhancement to Date discrepancies in México eDocument Cockpit app - SAP for Me
- 3523875 - Need to reflect Local Time in CSTNO (i.e. UTC-6) for Mexico in Manage Outbound Delivery – VL06O app
- 3522131 - Requirement to create Sales Volume Flexible Analysis in CSTNO (i.e. UTC-6) for Mexico
- 3523857 - Need to reflect Local Time in CSTNO (i.e. UTC-6) for Mexico in Manage Billing Document app
Keywords
time zone, UTC, Cloud, SMC, System Time, S/4HANA Cloud, S4HC, SAP S/4HANA Cloud Public Edition, cloud, 3SL, 2SL , KBA , BC-SRV-TIM-TZ , Time zones , Problem