Symptom
When opening Service > Tickets and opening the Create New Ticket section, the error message "You are not authorized to perform this action" is triggered.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Service work center.
- Go to Tickets view.
- Select the New "+" button.
- The error message "You are not authorized to perform this action" is triggered.
Cause
You have Disabled the CREATE_SERVICE_REQUEST Business Action Restriction for your Business Role.
Resolution
Please check the affected User's business role:
- Go to Administrator > Business Users
- Search for the user's name
- Click on Access Rights
- On Business Role Assignment check which role is assigned to the user
Follow the steps below to check and activate the missing restriction:
-
Go to the Administrator work center;
- Go on General Settings > Business Roles;
- Select the Business Role ABC (ABC represents the Business Role ID);
- Click on Edit;
- Go to the Fields & Actions tab;
- Scroll down to the Business Action Restrictions pane;
- You will see the CREATE_SERVICE_REQUEST has the Access Restriction as Disabled;
- Change to Unrestricted;
- Select the Save and Close button.
Keywords
New ticket error, Not able to create, not possible, cannot create, is not authorized, is unable to create
, KBA , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer core applications 2408