SAP Knowledge Base Article - Public

3514561 - Unable to Create Ticket - "You are not authorized to perform this action"

Symptom

When opening Service > Tickets and opening the Create New Ticket section, the error message "You are not authorized to perform this action" is triggered.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Go to Tickets view.
  3. Select the New "+" button.
  4. The error message "You are not authorized to perform this action" is triggered.

Cause

You have Disabled the CREATE_SERVICE_REQUEST Business Action Restriction for your Business Role.

Resolution

Please check the affected User's business role:

  1. Go to Administrator > Business Users
  2. Search for the user's name
  3. Click on Access Rights
  4. On Business Role Assignment check which role is assigned to the user

Follow the steps below to check and activate the missing restriction:

  1. Go to the Administrator work center;
  2. Go on General Settings > Business Roles;
  3. Select the Business Role ABC (ABC represents the Business Role ID);
  4. Click on Edit;
  5. Go to the Fields & Actions tab;
  6. Scroll down to the Business Action Restrictions pane;
  7. You will see the CREATE_SERVICE_REQUEST has the Access Restriction as Disabled;
  8. Change to Unrestricted;
  9. Select the Save and Close button.

Keywords

New ticket error, Not able to create, not possible, cannot create, is not authorized, is unable to create
, KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications 2408