Symptom
You are adding an extension field and you receive an error "Cannot create extension field in this UI; Extension Field limit reached; An exception was raised."
Also, If you try to modify the existing fields (like adding new values on list fields) you may receive the following message: "Modification of the field properties failed; There has been an exception".
Environment
SAP Cloud for Customer HTML5 and RUI UI
Reproducing the Issue
- Login to C4C.
- Go to any BO - open a record.
- Get into adaptation mode.
- Click on Add field.
- Select a field to be added.
- Error "Cannot create extension field in this UI; Extension Field limit reached; An exception was raised." occurs.
In case of adding the field via SDK when you try to enhance the XBO (add or edit the field) you will receive a dump.
Cause
There is a maximum limit of 745 extension fields (KUT + SDK) per BO & node combination a result of which you will be receiving an error message.
Resolution
To check the Limit Of Extension Fields per Business Object
You can have an overview of the fields under Administration work center:
- Go to Administrator work center.
- Open General Settings.
- Go to Adaptation Changes.
- Open Extension Field Usage.
- You will see the following information: Business object, number of fields created, allowed number of fields (remaining fields to create), aggregate length and aggregate length allowed (remaining size).
Keywords
Field, Form, SDK, Limit of fields, extension, field, limit, aggregate, length. , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Problem