SAP Knowledge Base Article - Public

3515058 - To-do Card URL Redirects to Source Instance Post-Refresh

Symptom

After a refresh or cloning, HPv4 direct links and To-dos are incorrectly points to the source tenant URL rather than the URL of the instance you are logged into. This problem occurs because direct links for HPv4 from the source tenant are transferred to the target instance as absolute/static links, rather than being adjusted to relative links.

Environment

SAP SuccessFactors HCM

Reproducing the Issue

  1. Log in to the target instance after a refresh or cloning.
  2. Navigate to the Todo Cards section.
  3. Click on Todo Card.
  4. Observe that the system redirects you to the source instance instead of staying within the target instance.

Cause

UI links for todo-based cards were not updated after the instance refresh or clone.

Resolution

Please submit a ticket to support under the component: LOD-SF-PLT-TOD with all the information for the cards that are impacted with screenshots. Our support team will need to request the Ops team to execute a script and manually rematerialize all to-do categories in the To-Do Foundation to fix the issue.

For support-related information, please check the internal memo included in this KBA or refer to the internal KBA below.

Note : If the problem persists after running the script, it should be addressed by the module-specific team.

Keywords

To-do Cards redirect to source instance, post refresh issue, To-do, HPV4, redirects URL to source , KBA , LOD-SF-PLT-TOD , To-Do List Issues , LOD-SF-PLT-REF , Instance Refresh , LOD-SF-PLT-IRT , Instance Refresh Tool , Problem

Product

SAP SuccessFactors HCM Core all versions