SAP Knowledge Base Article - Public

3515325 - Repeating error messages from the use of the SAC CAM support users appear in the traces

Symptom

In SAC, under System->Monitor in the trace section, below repeated error messages appear from CAM support users:

  • "SupportUserAPI.deleteSupportUser: Invalid support username"
  • "Function doHead has not been implemented."
  • "SupportUserAPI.getSupportUsers: No support users found"
  • "SupportUserAPI.logs: Get all users Tenant Id: 5"

Environment

SAP Analytics Cloud 2024.15.

Reproducing the Issue

  1. Login to SAC.
  2. Go to System >> Monitor >> Trace.
  3. Notice that there are repeated error messages from supportuser CAM_SUPPORTUSER.

Cause

Those messages are mainly for auditability and provide full transparency showing what happens in the background from CAM.

Resolution

An enhancement is planned to fix these traces in the upcoming wave 2024.21.

Keywords

sap analytics cloud, trace, monitor, cam, support user, activity log , KBA , LOD-ANA-ADM , SAC Administration , Problem

Product

SAP Analytics Cloud 1.0

Attachments

Pasted image.png