SAP Knowledge Base Article - Public

3515416 - Candidate from Recruiting is created with the wrong email address - Onboarding

Symptom

  • Candidates has one email address in Recruiting, it passes correctly to Onboarding (suite integration confirms that field 'emailInfo.email-address' is passing the right value), but once candidate reaches Onboarding side, another email is displayed.
  • Username is being created mistakenly.

Environment

  • SAP SuccessFactors Onboarding
  • SAP SuccessFactors Recruiting Management

Cause

In Recruiting, there are two fields: contact email and primary email. When a candidate creates their profile, both fields will have the same value. However, if the candidate changes their email later, only the contact email will update; the primary email is never editable. 

Resolution

The primary email is always sent to onboarding, regardless of whether it's mapped. And the Primary Email is going to be the one which Onboarding will create as Username, for example.

In this case, if the new email address from Recruiting should be the one used, customer would need to cancel and/or purge candidate in Onboarding and create a new profile for the candidate, this time with the desired email address as the primary one.

Keywords

wrong, email, address, pass, rcm, recruiting, different, onboarding, username, create, OBX, 2.0 , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , LOD-SF-RCM , Recruiting Management , Problem

Product

SAP SuccessFactors Onboarding all versions