SAP Knowledge Base Article - Public

3515472 - Sync Of Tasks From C4C To Server Side Add-in Doesn't Not Happen

Symptom

Users create tasks in C4C and expect these to be synced to the server-side add-in; instead, nothing happens.  

Environment

  • SAP Cloud For Customer
  • Server-Side Add-in Integration

Reproducing the Issue

  1. User creates tasks in C4C.
  2. These are not synced to the server-side add-in, even after forcing sync and reinitializing the mailbox. 

Cause

In the current product implementation, for task synchronization by default, tasks where the processor differs from the Owner will not be synchronized.

This is the expected design. The Employee ID is inserted into the Processor UUID field. So the problem basically lays on EmployeeUUID and ProcessorUUID having different IDs on the corresponding tasks. 

Resolution

Possibilities are listed below:

  1. Create a custom filter in CRM where they will see a list of desired tasks where the processor differs from the owner, specifying this filter in the synchronization settings at the user level for the task object.
  2. Change it in the customization profile.

Keywords

Employee; Owner; Processor; User; tasks; activities; synced; Server Side; Outlook; Add-in. , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To

Product

SAP Cloud for Customer core applications 2408