SAP Knowledge Base Article - Public

3515570 - Cache Issue Is Happening When Launching URL Mashup From C4C Environment

Symptom

After opening a created URL mashup inside the C4C, sometime later, a cache issue starts to happen.

Environment

SAP Cloud for Customer

Reproducing the Issue

1. Go to Sales work center, for example.
2. Open the Sales Quotes work center view.
3. Open the "123" quote.
4. Under "Products" facet, search for "ABC" URL mashup under "Add Products" section.
5. Click on the URL.
6. After some time, there is a cache issue and the screen gets in blank.

P.S: Sales and quotes were used just as an example, this can happen in any business object.

Cause

If the URL configured in mashup opens the expected application.
Then mashup is not holding any other responsibility of cache or incorrect data in that application.

Resolution

Please contact the embedded application owner for further findings.

Keywords

C4C; Mashup; Cache; URL; Data; Wrong; incorrect , KBA , AP-RC-GEN-MSH , Mashups , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions