SAP Knowledge Base Article - Public

3516758 - Time Efforts Replicated From FSM To C4C Not Displayed Under Time Entries Facet

Symptom

You are unable to see any Time entry which was replicated from FSM to C4C although you can see in the incoming Message payload that all the Time Entries data are present.

Environment

SAP Cloud for Customer core applications

Reproducing the Issue

  1. Go to Administrator Work Center
  2. Go to Web Service Message Monitoring View
  3. Search and Select the Message ID XXX (XXX is the Message ID of the incoming message from FSM)
  4. Click on View > Payload.
  5. See in the Payload "TimeEntry" data is present
  6. Now open the Ticket ABC to which the replication is performed (ABC is the Ticket ID)
  7. Go to Time Entries Facet
  8. See there are no records/entries

Cause

The user is not assigned the Work Center "Time Recording" and hence cannot see any entries under Ticket Time Entries facet.

Resolution

To see the entries under the Time Entries facet, the user should have been assigned the Time Recording Work Center.

Steps to assign "Time Recording" Work Center to a Business Role:

  1. Go to Administrator Work Center
  2. Go to General Settings View
  3. Under "Users" open "Business Roles"
  4. Search and select the Business Role to which the Work Center needs to be assigned and Click on Edit
  5. Under "Work Center and View Assignments" tab search for the Work Center ID "COD_SEOD_TR_WCFP" (Time Recording)
  6. Assign the Work Center by checking the box "Assigned to Business Role"
  7. Save

The user can now re-login and check the Ticket ABC again to see all the recorded Entries under the Time Entries facet.

Keywords

Time Entries , Entries , Ticket , Missing , Message , Payload , COD_SEOD_TR_WCFP , Time Efforts , KBA , LOD-CRM-SRP-TE , Time Entry , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer core applications all versions