Symptom
IPS sync is failing with the following error message:
- Header X-CSRF-Token not found among response headers
- An error has occurred while trying to retrieve a CSRF token. Caused by: Target host is not specified
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Check the IPS logs
- Check the log for the affected SuccessFactors
- Notice that it is failing for SAC target system with one of the errors below:
- Header X-CSRF-Token not found among response headers
- An error has occurred while trying to retrieve a CSRF token. Caused by: Target host is not specified
Cause
OAuth2TokenServiceURL is missing in the target system properties
Resolution
Customer needs to raise a ticket to LOD-SF-ANA-SAC.
Support team:
- For CF tenants:
Support team will review/fix the URL and OAuth2TokenServiceURL set to the SAC target system in IPS.
While adding the correct URLs the system will request for the password which will be shared by engineering team as per KBA 3051071.
IPS admin access needs to be granted by the customer to the support team.
Note to the Support team: Please review the internal memo.
- For NEO tenants:
Support team needs to contact engineering team, they will update the value for URL, OAuth2TokenServiceURL and the password via backend.
IPS admin access needs to be granted by the customer to engineering team.
Keywords
Connector cannot process more entities due to irreparable error Caused by: An error has occurred while trying to retrieve a CSRF token. Caused by: Target host is not specified, Header X-CSRF-Token not found among response headers, IPS sync, successfactors, SAP Analytics Cloud , KBA , LOD-SF-ANA-SAC-IPS , IPS configurations and Sync Job , Problem