Symptom
Requests for maintaining payment approvers of bank account from app Maintain Payment Approver for Multiple Bank Accounts are not available in My Inbox app.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Set the Bank Account Control Mode to WORKFLOW.
- Go to app Maintain Payment Approver for Multiple Bank Accounts, add or change payment approver.
- "Request created" is displayed, then go to app My Sent Requests.
- The "Next Processor" field of the created request is empty.
Cause
The combination of the following configurations will cause this issue:
1. Bank Account Control Mode: "Workflow" (in SSCUI 101025 - Define Basic Settings).
2. Grouping Options of Mass Change Requests: "Mass Change Pymt Appr: Group by Company Code" (in SSCUI 101025).
3. Account Type is setting to 01 (in app Manage Teams and Responsibilities).
The data sent to workflow is account type = * and company code = 0001. Then in workflow, it will try to match the predefine data(account type 01 and company code 0001), so it failed to determine the next processor and end with an error in workflow. Because * could not match to 01.
But in app Manage Bank Account, it doesn’t using this rule since it is a single one update.
Resolution
1. Go to SSCUI 101025 - Define Basic Settings.
2. Change the "Grouping Options of Mass Change Requests:" field to 'Mass Change Pymt Appr: Group by Company Code & Account Type'.
3. Go to app Manage Teams and Responsibilities, click through the BANK ACCOUNT MANAGEMENT team and set the BankAccountType to 01.
Then the requests sent from app Maintain Payment Approver for Multiple Bank Accounts should be available in the app My Inbox.
Note: After submitting the request, created requests can be checked out in app My Sent Requests whether the workflow has been triggered and who is the Next Processor.
Keywords
Workflow, Maintain Payment Approver for Multiple Bank Accounts, My Inbox, My Sent Requests, Change Payment Approver, Action Type 04, Grouping Options of Mass Change Requests. , KBA , FIN-FSCM-CLM-BAM-2CL , Bank Account Management (Public Cloud) , Problem