SAP Knowledge Base Article - Public

3517420 - Permission error when testing Employee Central Quick Actions in Joule

Symptom

Error while testing EC Quick Actions in Joule: 

  • Oops, you do not have permission to perform this action.

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Access SuccessFactors
  2. Click on Joule
  3. Ask to Change Phone Number as example
    1. I get the error message "Oops, you don't have permission to perform this action."

Cause

This is usually related to permissions and target population

Resolution

Check the related Employee Central Quick action permission target population to ensure the user is under this target population.

As the example for "Change Phone Number":

Employee Central Quick Action > Change Phone Number Permission > add the user under target population.

This is a required pre-configuration for using any Joule use case that related with EC Quick Actions. We strongly recommend you to review below content for further guidance:

Employee Central Quick Actions | SAP Help Portal

See Also

Employee Central Quick Actions | SAP Help Portal

Keywords

change phone number, joule change, EC quick action, phone number, change address, Use Cases for Employee Central Quick Actions, Oops, you do not have permission to perform this action, change actions in joule, permission error in joule , KBA , LOD-SF-PLT-DA , Joule in SuccessFactors , Problem

Product

SAP SuccessFactors HCM Core 2405