Symptom
Error while testing EC Quick Actions in Joule:
- Oops, you do not have permission to perform this action.
- The action isn't available right now. This could be due to certain settings not being enabled or permission restrictions
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Access SuccessFactors
- Click on Joule
- Ask to Change Phone Number as example
- Get one of the errors mentioned on Symptom
Cause
This is usually related to permissions and target population
Resolution
Make sure the affected user is granted with the Employee Central Quick action permission and also ensure the user have the correct target population for this permission (including themselves).
As the example for "Change Phone Number":
- Employee Central Quick Action > Change Phone Number Permission > user is granted with the permission and is under target population.
This is a required pre-configuration for using any Joule use case that related with EC Quick Actions. We strongly recommend you to review below content for further guidance:
Note: Joule doesn't support Global Assignment and Concurrent Employment (GA/CE). The data provided by Joule is based on the user's primary employment.
See Also
Keywords
change phone number, joule change, EC quick action, phone number, change address, Use Cases for Employee Central Quick Actions, Oops, you do not have permission to perform this action, change actions in joule, permission error in joule , KBA , LOD-SF-EC , Employee Central , LOD-SF-PLT-JOU , Joule in SuccessFactors , Problem
SAP Knowledge Base Article - Public