Symptom
Error while testing EC Quick Actions in Joule:
- Oops, you do not have permission to perform this action.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Access SuccessFactors
- Click on Joule
- Ask to Change Phone Number as example
- I get the error message "Oops, you don't have permission to perform this action."
Cause
This is usually related to permissions and target population
Resolution
Check the related Employee Central Quick action permission target population to ensure the user is under this target population.
As the example for "Change Phone Number":
Employee Central Quick Action > Change Phone Number Permission > add the user under target population.
This is a required pre-configuration for using any Joule use case that related with EC Quick Actions. We strongly recommend you to review below content for further guidance:
See Also
Keywords
change phone number, joule change, EC quick action, phone number, change address, Use Cases for Employee Central Quick Actions, Oops, you do not have permission to perform this action, change actions in joule, permission error in joule , KBA , LOD-SF-PLT-DA , Joule in SuccessFactors , Problem